Situation
Du hast einen Export über den Rechnungsdatenservie 1.0 gestartet. Der Export eines oder mehrerer Belege schlägt mit dem Fehler 'Ungültige Datei' fehl.
Ursache
Eine oder mehrere Dateien im Export sind ungültige PDFs. Das passiert manchmal, wenn PDFs bei der Erstellung nicht richtig kodiert werden. Oder die Dateien aus anderen Gründen fehlerhaft sind.
Lösung
Lade die Datei einmal runter und prüfe, ob du sie überhaupt öffnen kannst. Manchmal klappt schon das Öffnen oder Anzeigen schon nicht. Dann ist die ganze Datei fehlerhaft. Hier müsstest du jetzt einmal den Lieferanten bitten, die Rechnung nochmal zu schicken oder den Scan wiederholen.
Wenn du die Datei öffnen und anzeigen kannst, ist vermutlich die Kodierung des PDFs fehlerhaft. Du kannst die PDF Datei einmal runterladen und erneut als PDF exportieren bzw. speichern. Am besten lässt du den Lieferanten auch von dem Problem wissen, damit er es für die Zukunft direkt bei sich beheben kann.
Hier geht es zur offiziellen DATEV Dokumentation für den Fehler #DCO1004.